[Mageia-dev] PostgreSQL conflicts

Frank Griffin ftg at roadrunner.com
Mon Apr 25 18:02:47 CEST 2011

This has been discussed in several threads in Cooker over the years.  
Every new postgreSQL package conflicts with the previous version.  It 
neither replaces it, nor can it be installed alongside of it, e.g.

Some requested packages cannot be installed:
lib64pq9.0_5-9.0.4-1.mga1.x86_64 (due to conflicts with 
lib64pq8.4_5-8.4.8-1.mga1.x86_64, due to conflicts with 
postgresql8.4-8.4.8-1.mga1.i586 (due to conflicts with 
postgresql8.4-8.4.8-1.mga1.x86_64 (due to conflicts with 
postgresql9.0-9.0.4-1.mga1.x86_64, due to conflicts with 
postgresql8.4-server-8.4.8-1.mga1.x86_64 (due to unsatisfied 
postgresql8.4[*][>= 8.4.8-1.mga1])
postgresql9.0-server-9.0.4-1.mga1.x86_64 (due to unsatisfied 
lib64pq9.0_5[*][>= 9.0.4-1.mga1])

IIRC, many postgreSQL version bumps won't work with the previous 
version's DB files, requiring that tables be unloaded under the old 
version and reloaded under the new, and that was the rationale for not 
having newer versions silently replace older ones.  But I've never 
understood why the versions can't be installed side-by-side, in 
version-specific directories.

Then there's the question, with multiple versions, of which one is the 
"default", and how you switch this at the user or sysadmin level.

I recall several conflicting comments about whether the current setup is 
correct, but I don't recall any resolution.  What is Mageia's policy on 
this going to be ?  I believe postgreSQL is installed automatically if 
the Database group is selected, which means that a lot of 
unsophisticated users are going to hit these conflicts every time a new 
version appears.

More information about the Mageia-dev mailing list