[Mageia-dev] Please ensure that packages have higher version than in mandriva 2010.2

Thomas Backlund tmb at mageia.org
Sun May 1 14:07:58 CEST 2011

sön 2011-05-01 klockan 12:39 +0300 skrev Bruno Cornec:
> Thomas Backlund said on Sun, May 01, 2011 at 01:56:21AM +0300:
> > Or simply fixed by adding an epoch
> Oh, please no !!!
> Epoch is somewhere the negation of versions. And then you have to
> embedded it all the time in all packages. 

Epoch was designed for issues when you want to fix versioning or force a

In this case, you want to fix the versioning as it was done in mdv, and
from rpm/urpmi point of view force a downgrade 
( < 2.29.3)

> I think we should have a rule to avoid as much a possible an epoch.

We do, when it comes to Cauldron -> Cauldron changes/reverts.

But upgrades from stable releases, it will be added if it is needed to
provide a simple upgrade path, no exceptions.

> Most of the time it's just for avoiding an incompatibility which will
> force the distribution to keep it for the rest of its life. So adopting

Thats the price you have to pay when you want to alter versioning
downwards or otherwise fix it...

> one should be only rare, and incompatibilities are generally solved with
> the +1 version. So if it's documented ...


rpm/urpmi does not read release notes, errata or other documentation
(and neither does most endusers)

rpm/urpmi only cares about epoch:version-release

And we stated from the beginning of Mageia that we will support upgrade
from 2010.1/2

So we dont do exceptions for package(r)s

So, either you or someone else will have to add the epoch to satisfy
rpm/urpmi upgrade path, and it needs to be done quickly as we are soon
to enter release freeze and release RC.


More information about the Mageia-dev mailing list