[Mageia-discuss] password-less ssh

Deri James deri at chuzzlewit.demon.co.uk
Sat Sep 24 18:30:15 CEST 2011

On Saturday 24 Sep 2011 11:32:39 Juergen Harms wrote:
> On 09/24/2011 12:06 PM, Maarten Vanraes wrote:
> > so you're saying that ssh doesn't accept authorized_keys file if it's a
> > link?
> That is the evidence - but it did somewhere (couple of weeks back) in
> the past, I have used this approach for years.

It "StrictModes" is turned on in sshd_conf I assume the permissions of the 
link itself is checked. Another possibility is to set AuthorizedKeysFile to 
point to your file in /etc.


> > have you tried mount --bind it?
> I had not thought about this alternative - I will try and come back with
> the result (do not have much experience with mount --bind, want to go
> slowly). That means linking the entire .ssh directory. A simple symbolic
> link of the entire directory never (if my memory is right) worked, that
> is why I linked individual files. Would be a simplification if a mount
> --bind can do the job

More information about the Mageia-discuss mailing list