[Mageia-discuss] Strange behavior after kernel update

TJ andrewsfarm at gmail.com
Sun Sep 25 14:55:38 CEST 2011

On 09/25/2011 04:27 AM, Claire Robinson wrote:
> On 25/09/11 02:39, TJ wrote:
>> I'm using the 32-bit version of Mageia with a Sempron 3100+ processor,
>> Asus K8V-MX/S motherboard, 2GB DDR RAM, and an nVidia Geforce 6200 AGP
>> video card. I'm using the latest non-free video card driver amd I also
>> have the vendor's generic for-any-Linux version 4.1.2 of VirtualBox
>> installed.
>> After updating the kernel earlier today, I attempted a reboot. The GUI
>> boot screen came up, and the progress dots showed progress, but it was
>> VERY slow. Not entirely unexpected because the new nVidia and VirtualBox
>> modules had to be installed, but this was far longer than I had ever
>> seen before. Normally I would have used the escape key to go to
>> "verbose" mode to see what was going on, but it didn't function, and the
>> message that I could do so didn't appear.
>> The progress dots eventually showed progress all the way to the end, and
>> then it was "stuck" there. After about three minutes I used the reset
>> button to reboot, using the old kernel. That worked normally. I then
>> shut down and tried the new kernel again, with the same result as before.
>> Another reset, but this time I booted into safe mode. This time the text
>> showed the nVidia and VirtualBox modules being installed, then went to a
>> command line. I issued a "halt" command and started again, once again
>> using the GUI bootscreen. This time, the "Press escape for verbose mode"
>> message showed up, and the boot proceeded completely normally. I haven't
>> tried everything yet, but so far it's working perfectly.
>> I haven't the slightest idea of why this happened, but I thought
>> somebody should know.
>> TJ
> You may find mkinitrd was building a new image, which can take a long
> time, especially when coupled with module rebuilds.
> Are there any clues in the dmesg or syslog?
> Claire
Not to me, but then I couldn't tell anyway. This kind of troubleshooting 
is very much beyond my skills, and I really don't know what looks right 
and what looks wrong. I'm simply a Linux user, more skilled than some, 
less skilled than many.

One thing that I remember now though... During the "strange behavior" I 
don't recall seeing much of any indication of hard drive access, but 
when I booted in safe mode there was what I would consider a normal 
amount for installing modules in a new kernel.


More information about the Mageia-discuss mailing list