[Mageia-discuss] System won't boot after hardware upgrade

Chopin Sébastien contact at sebastienchopin.fr
Fri Sep 30 11:24:29 CEST 2011

Le 22/09/2011 11:51, xi a écrit :
> Hi,
> I have changed my motherboard and Mageia now refuses to boot (kernel 
> panic after trying to mount /dev/sda1 : "waiting for device sda1 to 
> appear (timeout 1 min), ...").
> I think I know the reason of my problem : the initrd does not load the 
> correct driver for my "new" IDE controller, so it can't mount my disk 
> (driver for old motherboard is pata_amd and new driver is pata_via).
> I tried to play with mageia rescue CD, but I am unable to regenerate 
> the initrd with the correct IDE driver (in fact, the rescue CD doesn't 
> even contain the mkinitrd command).
> My question is : how can I solve my problem, given that I have only 
> one rescue CD and my HD containing mageia that don't boot anymore ?
> A long time ago in the perfect world of Mandrake (:P), all IDE 
> controller were included _inside_ the kernel and _not_ compiled as 
> modules*, so this problem never occured because all IDE drivers were 
> always "loaded" (thus allowing my system to be booted on any computer).
> Now that the ide/sata drivers as compiled as modules, why don't the 
> initrd try to load all the ATA drivers if mounting of "/" fails ?
> (from my point of view, it is a much better solution than failing with 
> a kernel panic ...)
> Thanks for your help,
> Xavier
> *this is _my_ interpretation, I may be wrong.
Have you tried to make an installation again with the option "Upgrade" ?


More information about the Mageia-discuss mailing list