[Mageia-discuss] Vicious problem with missing hal in alpha 1

Wolfgang Bornath molch.b at googlemail.com
Sat Nov 26 12:47:52 CET 2011

2011/11/26 Juergen Harms <Juergen.Harms at unige.ch>:
> I successfully installed alpha 1 from the brand new iso DVD. Install goes
> smoothly, but after booting the system, I come to a screeming stop:
> When I try to run urpmi (from a console) for installing update packages,
> urpmi refuses with the message that the hal daemon is not running.
> rpm -q in fact confirms that hal is not installed (I had done a perfectly
> standard KDE install). Doing "urpmi hal" gives the evident result: it lists
> 9 packages to be installed (among which is hal) but then fails because the
> hal daemon is not running.
> That puts a stop to any further testing. Is there a work around that allows
> to install hal while the hal daemon is not running?

Yes. :)
I ran into the same, then I looked at the media and realized that
there is "cdrom" still activated (the installation medium). This could
not be found because HAL was not running. De-activating this medium
worked around the problem, urpmi installed (almost) all 240 updates.


More information about the Mageia-discuss mailing list