[Mageia-discuss] audio recording (from Line In) doesn't work in Mageia 2

David Walser luigiwalser at yahoo.com
Sat Dec 29 17:30:20 CET 2012

I have an ATI TV Wonder VE video card which doesn't handle audio internally, it just pipes it out a 1/8" audio cable which you plug into the Line In input in the sound card, and you record the audio from that.  For years, I've been using the script below to record TV from it.  The aumix command sets the IGain mixer channel, which controls the volume of the audio that gets recorded.  Up through Mageia 1, this worked fine.  Now in Mageia 2, I get no sound.

aumix -i 60
mencoder -tv driver=v4l2:width=640:height=480:adevice=/dev/dsp:norm=ntsc:input=0 tv:// -o tv.avi -oac mp3lame -ovc lavc -lavcopts acodec=libmp3lame:abitrate=64:vbitrate=1800:vhq -lameopts vbr=3:br=64 -srate 44100 -vf crop=608:456:14:10 > /dev/null 2>&1
aumix -i 0

I also tried running VLC and doing Open Capture Device, and I get no sound there either.  Any ideas how to get this working now?

More information about the Mageia-discuss mailing list