[Mageia-discuss] audio recording (from Line In) doesn't work in Mageia 2

David Walser luigiwalser at yahoo.com
Sat Dec 29 22:45:04 CET 2012

AL13N wrote:
> Op zaterdag 29 december 2012 14:07:23 schreef David Walser:
>> David Walser wrote:
>> > Christiaan Welvaart wrote:
>> >> On Sat, 29 Dec 2012, David Walser wrote:
>> >>> I have an ATI TV Wonder VE video card which doesn't handle audio
>> >>> internally, it just pipes it out a 1/8" audio cable which you plug into
>> >>> the Line In input in the sound card, and you record the audio from that.
>> >>> For years, I've been using the script below to record TV from it.  The
>> >>> aumix command sets the IGain mixer channel, which controls the volume of
>> >>> the audio that gets recorded.  Up through Mageia 1, this worked fine.
>> >>> Now in Mageia 2, I get no sound.
>> >>> 
>> >>> aumix -i 60
>> >>> mencoder -tv
>> >>> driver=v4l2:width=640:height=480:adevice=/dev/dsp:norm=ntsc:input=0
>> >>> tv:// -o tv.avi -oac mp3lame -ovc lavc -lavcopts> 
>> > acodec=libmp3lame:abitrate=64:vbitrate=1800:vhq -lameopts vbr=3:br=64
>> > -srate 44100 -vf crop=608:456:14:10 > /dev/null 2>&1> 
>> >>> aumix -i 0
>> >> 
>> >> Well all kinds of things can be wrong. Does the TV card output sound?
>> > 
>> > The TV card is fine, all that's changed is upgrading to mga2.
>> > 
>> >> Maybe the input selector of the sound card is set to microphone.
>> > 
>> > How would you check/change that?  Why would it get messed up all of a
>> > sudden?> 
>> >> Why are you using OSS instead of alsa directly?
>> > 
>> > That's what mencoder uses.  It should work fine.
>> I tried changing adevice=/dev/dsp to the following things, which all also
>> didn't work: alsa:adevice=hw.0,0
>> alsa:adevice=hw.0,1
>> alsa:adevice=hw.0,2
>> Here are the sound and TV devices from lspcidrake.  This is smelling like a
>> kernel bug to me. snd_hda_intel   : Intel Corporation|82801JI (ICH10
>> Family) HD Audio Controller bt878           : Brooktree Corporation|Bt878
>> Audio Capture [MULTIMEDIA_OTHER] (rev: 11) bttv            : Brooktree
>> Corporation|Bt878 Video Capture [MULTIMEDIA_VIDEO] (rev: 11)
>> >> Try to get things working with alsamixer if aumix doesn't work...
>> > 
>> > aumix seems to be working fine, it still sees the IGain channel and can
>> > set it just fine.  I think something else is wrong.
> it could still be that channels are being changed in kernel driver, perhaps 
> you can with alsamixer try to select the correct line-in function, and up the 
> volumes that could maybe have effect?

alsamixer seems broken on mga2.  Is there some other way to check/change the selected capture device?

I wanted to reboot to the mga1 kernel to see if that would work, but that was an unproductive adventure.

I installed the mga1 kernel which pointed /boot/initrd.img to the mga1 kernel's initrd, which was generated of course by dracut, but didn't 
work, and I couldn't boot any kernel.  I booted to the rescue from the installer and re-installed the mga2 kernel, which fixed the initrd 
links, so then I could boot the mga2 kernel.  I restored the mga1 kernel's initrd from the backups I made before the upgrade, so then I could 
also boot the mga1 kernel, but when KDM came up the mouse and keyboard didn't work and hitting the power button didn't shut down, so I had to 
hold the power button to kill it.  So I couldn't test if it works under the mga1 kernel.  Somewhere during this process, grub got messed up 
too, because /boot/grub/device.map got renamed to /boot/grub/device.map.old and replaced with an empty one, so I had to fix that by hand.

More information about the Mageia-discuss mailing list