[Mageia-discuss] Keyboard gone after update from Mandriva

TJ andrewsfarm at gmail.com
Thu Jan 12 22:15:39 CET 2012

On 01/12/2012 02:49 PM, TJ wrote:
> On 01/12/2012 10:43 AM, Renaud (Ron) Olgiati wrote:
>> After updating from Mandriva 2010.1 to Mageia 1, I have this keyboard
>> problem:
>> The (USB) keyboard, which is recognized by the BIOS during boot-up, no
>> longer
>> does anything when I get to the Grub screen. (So I cannot boot in safe
>> mode)
>> After which the computer freezes displaying "Mageia" and nine dark polka
>> dots.
>> No such problem when I try to boot with a PS2 keyboard; with USB keyboard
>> booted perfectly under Mandriva.
>> Any idea ?
>> TIA,
>> Ron.
> Now that I think about it, I recall that when I switched from a PS2
> keyboard to a USB one, I had to change a BIOS setting to get it
> recognized by Grub. Once it timed out and booted the default, the
> keyboard worked perfectly. Had me scratching my head for a few days, I
> can tell you.
> But that was with Mandriva 2010.0 or 2009.1 and you said it worked with
> Mandriva, and you also said it froze later, which mine didn't. And my
> incident was with an existing install, not a new one.
> So maybe your problem is different. Still, it might not hurt to check.
> If you have such a BIOS setting and changed it before, perhaps something
> caused the BIOS to reload the defaults.
> It's been a while and I'm not sure about this, but it almost seems like
> I had to use a PS2 keyboard to get into the BIOS, until I changed that
> setting. Sigh. Wish I could remember more.
> TJ
OK, I looked it up, and that was with an older motherboard and BIOS from 
Biostar, and it had to be Mandriva 2009.1. My newer motherboard saw the 
usb keyboard automagically.

So it probably doesn't help.


More information about the Mageia-discuss mailing list