[Mageia-discuss] Glitch with nvidia FX 5500 card driver

Luca Olivetti luca at ventoso.org
Thu Jan 19 12:05:18 CET 2012

Al 19/01/2012 11:51, En/na Florian Hubold ha escrit:
> Am 19.01.2012 09:55, schrieb Luca Olivetti:
>> Al 19/01/2012 3:43, En/na TJ ha escrit:
>>> After that, I tried turning off the desktop effects, but that was even
>>> worse in its own way because while the menu scrambling wasn't as
>>> prominent, when I went to shut things down the background went away and
>>> something from out of an old cache was displayed.
>> Something similar is happening here, when the shutdown menu shows, the
>> background is "scrambled" (colored noise), but it's a completely different
>> card (an acer aspire 722 with a radeon hd6250) with a completely different
>> driver (catalyst driver downloaded from amd, the one from the repositories
>> didn't work).
>> I didn't touch desktop effects at all, so I cannot say if they are enabled or
>> not.
>> Maybe the root cause of the problem is similar.
> nonfree radeon-firmware package is installed, and either the initrds have been
> regenerated since (via "bootloader-config --action rebuild-initrds" as root)
> or you've done a kernel update since?

No kernel updates, I just let harddrake install the propietary module 
and it didn't work (it didn't recognize the card and fell back to vesa).
I then downloaded the catalyst driver from amd and used its installer 
(which probably messed up the system but it seems to work, though it 
doesn't come back after a suspend).
According to this page
the free driver should also work (and should have no problem with 
suspend/resume), but it needs mesa 7.11 while mageia has 7.10.


More information about the Mageia-discuss mailing list