[Mageia-discuss] home network using broadband router

imnotpc imnotpc at Rock3d.net
Mon Mar 12 00:27:46 CET 2012

On 03/11/2012 05:59 PM, WALKER RICHARD wrote:
> On 10/03/2012, imnotpc<imnotpc at rock3d.net>  wrote:
>> You mentioned in an earlier post that the mga1 box worked once after you
>> commented out the RPCMOUNTD_OPTIONS="--port 4003" option in
>> /etc/sysconfig/nfs-server. I just checked the mga1 test server I set up
>> yesterday and this option isn't set at all. Is it possible you are
>> mixing files from different Mandriva/Mageia versions? Perhaps try
>> un-installing nfs-utils and deleting all it's config files and start
>> again with a clean package install.
> Hi Jeff, it took a little more time than I thought but I have found
> the cause and the cure for the problem with nfs-server function on
> Mageia 1. In the process I learned how to use an rpm source package to
> patch and rebuild the offending file for the nfs-utils package.
> Tomorrow; the World!
> First up, the problem is well known and of quite some vintage. It only
> affected nfs-utils v1.2.3 so versions just prior and subsequent (as in
> v1.2.5 in Mageia 2 Cauldron) are OK. Hence the Mandriva 2010.2 worked
> as did my MGA2 Beta1 server.
> This reference tells the whole story;
> https://bugzilla.linux-nfs.org/show_bug.cgi?id=190
> So the proposed fix was first seen in October 2010. I have used the
> proposed patch to rebuild the nfs-utils-1.2.3-2.1.mga1 package and it
> works perfectly well with the --ports option for rpc.mountd.

Very good.

> In the course of all this I can confirm your observation that in a
> fresh MGA1 install of the nfs server the RPCMOUNTD_OPTIONS= entry is
> blank in /etc/sysconfig/nfs-server. My guess is that it is only set to
> a specific port number when you use the personal firewall with a hole
> for NFS. I don't see how you could configure the firewall if the
> listening port were to be some random value, so I reckon it's a good
> guess.
> I'll report this bug for the MGA1 package and we should have the fixed
> version out quite soon.

This is an age old issue with these tools since they were originally 
designed to use random ports prior to the common use of client 
firewalls. I've been hacking their config files since I first started 
using Linux to force them to use specific ports and it's always been a 
PITA. As annoying as these issues are they are at least not as bad as 
trying to get Samba to work in a heterogeneous network. Glad you got it 
figured out.


More information about the Mageia-discuss mailing list