[Mageia-discuss] Mageia 2 upgrade testing - we're ready for more people to give it a try.

David W. Hodgins davidwhodgins at gmail.com
Fri Apr 6 04:37:23 CEST 2012

I ran a test today, upgrading from Mageia 1 to Cauldron,
as part of the qa testing for Mageia 2.

On my 7 year old i586 system, a Mageia 1 install containing
Gnome, KDE, and LXDM, the upgrade install of 2,187 packages
took about 2 hours.  There were no package or file conflicts.

There was one postinstall scriptlet that failed, which has
been reported and already fixed.

There was one postuninstall scriplet that failed, which will
likely result in an update for Mageia 1.

Neither of these two bugs caused any problems in the resulting

This is the cleanest upgrade distribution version upgrade I've
ever seen.

The only other problem I saw, were that, after installing 2100
packages in one transaction, the distribution dialog appeared
to hang, for about 20 minutes.  A little checking during the
apparent hang, showed that is was processing 260,516 file

After the delay, the dialog saying to reboot, just closed when
the reboot button was selected.  After manually rebooting, the
system came up properly, with everything working, that I checked.

The upgrade testing has reached the point where the testing
needs a wider variety of hardware and package selection, so
more testers would be appreciated.  If you have the time, and
available disk space, please consider trying out the upgrade
procedure, and reporting any problems found.

Note that, at this point in time, upgrade testing will result
in an installation that will get it's updates from the Cauldron
repositories, which by their nature, can be unstable at times.
Don't use this for a production system!   Make sure you have
a full backup, and tested restore procedures, just in case.

The easiest way to test the upgrading from Mageia 1 to
Cauldron, is to open a terminal and run the commands
$ sudo urpmi --auto-update
$ killall mgaapplet
$ mgaapplet --testing &
Then select the More information button on the dialog
that opens up, and follow the prompts.

During my test, 1.1GB of data was downloaded to /var,
so make sure you have the space available. Also, make
sure /boot has at least 24MB of free space.

The update can also be done using a boot.iso image
as described at https://wiki.mageia.org/en/Boot.iso_install
The boot.iso can be downloaded from
or the corresponding directory of your favourite mirror.

Both of the above methods require a reasonably fast and
stable internet connection.

A third option, would be using the beta 2 dvd iso image,
which can be downloaded from
Note that a lot of bugs have been fixed since the beta 2
iso images were created.  Be sure to install updates as
part of the installation, or use "urpmi --auto-update"
after the first reboot. Do not use rpmdrake from the beta
2 iso.

There are some known bugs that are being worked on, but
have workarounds available.

If you have /usr on a lvm logical volume, the initrd from
the upgrade will fail to boot.  The workaround for this
is to add the kernel option rd.break=pre-pivot during the
first boot.

To edit the kernel options, press f3 on the grub selection
menu, then select defaults, the type a space followed by
the option, then press enter.

Once the system starts to boot, a bash shell will open up
where you can enter the commands ...
# lvm vgchange -a y
# exit
A second shell will open after the pivot to the new root.
Just type in "exit" again, and press enter.
Once the system has booted, open a terminal and run the
$ sudo dracut -f
That will create a new initrd, that will properly mount
the /usr on a logical volume, for future boots.

This bug is being tracked in

Another problem that requires a workaround for now, is
that for some (most?) ide controllers, the order of
the loading of kernel modules will result in ide hard
drives being assigned /dev/hd? instead of /dev/sd?.
Also, ide cd/dvd drives will be assigned /dev/hd?
instead of /dev/sr?, making them inaccessible.

If your system has ide drives, before upgrading, run
the command
$ lspcidrake|grep IDE

The first part of the output is the kernel module that
should be used for the ide controller on your system.
It will be something like pata_via, pata_amd, or
ata_piix.  Make note of which module is used.

After the upgrade, modify /boot/grub/menu.lst, to add
the option rdloaddriver=pata_via (replacing pata_via
with the module used for your ide controller.

This bug is being tracked in

The more people we have testing now, the better chance we
have of having a great release, when Mageia 2 is released.

Remember, Mageia 2 is a community release.  The more people
who contribute, the better the release will get.  You can
help too.

The qa team could really use more people.  When Mageia 2 does
get released, our workload will double, as many updates will
require testing in both Mageia 1 and 2.

Even if you can only put in a few hours per week, every bit
helps.  All you have to do to join, is subscribe to two
mailing lists, then pick updates you have the hardware
and software needed to test, and start testing, reporting
your results on bugzilla.

See https://wiki.mageia.org/en/QA_Team for more details.

Regards, Dave Hodgins

More information about the Mageia-discuss mailing list