[Mageia-discuss] Unable to activate partitions - - [SOLVED]

Doug Laidlaw laidlaws at hotkey.net.au
Sun May 27 09:51:11 CEST 2012

I deleted this but have reconstructed it from the Archives:

On Sat May 26 Doug Laidlaw wrote:

"This may be the same problem as the "very long boot." I am not
qualified to say.  But Dimitrios implies that his system boots
eventually.  Mine gives up and drops me to a shell.

"Following some fiddling around with Gentoo on my "fiddling" partition,
I put Cauldron back.  I could get into Cauldron O.K., but when I tried
to boot into Mga2, it kept stopping with a kernel message that it
couldn't activate a partition with "Dependency failed."  One by one I
excluded the partitions from /etc/fstab until I would no longer have a
usable system.  With the last one, I typed Ctrl-D and got in.  I was
then able to activate the excluded partitions and mount them with the
usual "mount" command.  Now I am afraid to reboot.

"In addition it said that the two test partitions had no journals,
although they were reformatted before I installed Cauldron."

Most of these errors sorted themselves out, except for the second test 
partition, which gave 

"couldn't mount because of unsupported optional features (240)"

I googled for that. At LinuxQuestions.org was a case with a very
similar history:


The user there had previously installed ArchLinux.  The fix was to
change the fs type in /etc/fstab from ext3 to ext4.  That worked for
me as well.  To quote from the thread:

"ext3 and ext4 are very similar file systems. well ext4 is formed from
ext3 so ext3 back compatibility won't be broken. so Slackware said
unsupported optional features were actually normal ext4 features."

Hope this helps somebody.  I always say that no problem arises for the
first time (well, that can't be literally true.)  The answer is out
there somewhere.



More information about the Mageia-discuss mailing list