[Mageia-discuss] Need help recovering execute permission on local files

Len Lawrence tarazed25 at gmail.com
Mon Jun 11 16:53:53 CEST 2012

On 11/06/12 12:28, Doug Laidlaw wrote:
> On Mon, 11 Jun 2012 11:33:46 +0100
> Len Lawrence<tarazed25 at gmail.com>  wrote:
>> After a warm reboot this morning I found that I no longer had the
>> ability to run my own commands even though the permissions are correct
>> and ownership is lcl (uid=500).  User system commands are OK so
>> running a script via ruby for instance works but trying to execute the
>> script by itself fails even though it is fully executable.  This
>> applies to all my local bin commands.  Command aliases however do work
>> as long as they do not involve running any of my bin files.
>> Even root cannot execute these bin commands; same message "Permission
>> denied".
>> In addition the system has switched me to autologin.  Trying to run
>> mcc I was told it cannot be run in console mode (??).  If I login as
>> su mcc comes up in console mode, which I am not inclined to use.
>> The hostname on this machine is belexeuli; this does not appear in
>> the command prompt: [lcl at localhost ~]$
>> After su: [root at belexeuli lcl]#
>> This may all have something to do with my adding groups and changing
>> group ids yesterday in my attempts to implement a viable sudoers
>> command.  It worked and I could log out and in again without any
>> problems.  I even managed a reboot without trouble but today is
>> another story.
>> I suspect that solving these multiple problems is beyond my technical
>> skill even with help so a full reinstall is probably the best bet.
>> However I will await any comments.
>> Len
> You say that the permissions are correct, but do they include execute
> permissions?  The prompt difference may be simply that root's prompt is
> no longer the same as a user's prompt.  It is set by a config file for
> each user.  You can see the code for it by typing "echo $PS1" In my
> case, that gives "[\u@\h \W]\$"  The \h puts in the hostname.  You can
> change it for the current session by typing at the user prompt:
>      PS1="[\u@\h \W]\$"
> You can make that permanent by putting it in your .bash_profile, where
> it should override the other at your next login, but really, it is only
> a workaround.
> With so many issues, I would do a full reinstall, but more knowledgeable
> people tell me it is the easy way out.
> HTH,
> Doug.
Followup to my last message, out of sync.

Logging out and in again solved the gui problem for root.  No need to 
reinstall then.


More information about the Mageia-discuss mailing list