[Mageia-discuss] Problems with Local Mail - SOLVED?

Anne Wilson annew at kde.org
Tue Jun 26 19:19:14 CEST 2012

Hash: SHA1

On 25/06/12 17:23, Frank Griffin wrote:
> On 06/25/2012 11:43 AM, Anne Wilson wrote:
>> It's odd, but I may have solved the problem. That said, I still
>> don't understand why. During the time I've been trying to solve
>> this, I have made two changes. First I added a newline character
>> in /var/spool/mail/anne - this seems to have disappeared, so I
>> doubt if that was the reason. The other change was to make the
>> ownership anne:mail. Maybe that helped?
> I thought you had posted earlier that you changed the ownership to 
> anne:mail and that didn't help ?  That is the correct ownership.
> If you're using IMAP through TB, your mail folders will be under 
> $HOME/.thunderbird/xxx.default/ImapMail/servername.  The problem
> you describe with /var/spool/mail/anne can only occur if your MTA
> (postfix) doesn't have write authority to that file.  In fact, I
> notice on my system that my /var/spool/mail/ftg file has ownership
> ftg:mail, but the permissions are only rw-------, so I guess
> postfix must be assuming an euid of the recipient before trying to
> write to the file, i. e. the group shouldn't matter.
> In any case, if you can do mail anne Subject: Test line 1 CTRL-D
> and it gets through to /var/spool/mail/anne, then it's working.  If
> it's not, try renaimng the file as root, rerun the test, and see
> what gets created for that file.
> If you still see the message, try to identify what's issuing it.
> It's possible that if TB somehow got hooked up with that file, it
> may be trying to auto-compact it or something.

That was interesting.  The message was delivered to an account called
System, type Unix Movemail, server name localhost.  Not sure, but it
looks as though maybe I set that up thinking that I didn't have any
provision for local messages.  Now it's beginning to make sense.  It
really does look as though it was a permissions problem, in not having
mail as the group.  When I said it hadn't helped, maybe I hadn't
restarted after the change.

Sorry if this all sounds confused.  Family problems are taking much of
my time just now and I keep dropping the ball.  Still, I've learned
some useful stuff.

Thanks again, everybody.


- -- 
Need KDE help? Try
http://userbase.kde.org or
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


More information about the Mageia-discuss mailing list