[Mageia-dev] Importing RPM Spec File Syntax
cazzaniga.sandro at gmail.com
Sat Jan 15 11:24:52 CET 2011
Le 15/01/2011 11:08, Remy CLOUARD a écrit :
> Here’s a proposal:
> Patches must be named in a very explicit manner to make it very clear to
> what version it was originally applied. To that end, a patch needs to
> follow the convention of
> * [package_name] is the name of the package it applies against, such
> as 'shadow-utils' or 'gnupg'
> * [version] is the version of the program this patch was developed
> against, such as 1.0. The name of the patch should not change, even
> when it is rediffed, because the version allow to see in a blink since
> when this patch has been there. If you happen to see a patch that does
> not apply anymore, and rediff it, ask the package maintainer if it has
> been sent upstream, and why it hasn’t been merged, and send it
> upstream if you think it should be merged.
> * [description] is a short description of the patch's purpose.
> Example: foo-1.0-fix-str-fmt.patch for a patch that fixes string format
I'm okay for naming patches as you say. It's clean and clear, we
understand well what a mistake they correspond.
IRC: Kharec (irc.freenode.net)
More information about the Mageia-dev