[Mageia-discuss] Strange font color

Frank Weng (a.k.a. Franklin) franklin at goodhorse.idv.tw
Mon May 9 06:43:51 CEST 2011

Hi, thanks for your reply.

Please see below.

Ahmad Samir 於 0100-05-09 寫道:
> On 8 May 2011 17:52, Franklin Weng <franklin at goodhorse.idv.tw> wrote:
> > Hi list,
> > I just installed Mageia 1 Beta2, and found that this problem still
> > occurred. So I came here to ask if you could give me any hint.
> > This problem only happened on my laptop, which uses intel GM965 on-board
> > display chip.
> > It has been a problem since Mandriva 2010.1 and 2010.2.  I'm not sure if
> > it had the same problem on Mandriva 2010.0.
> > Please see this screenshot:
> > http://www.goodhorse.idv.tw/files/screenshot1.png
> > As you can see, in the KDE menu only the first item has words on it.  The
> > other items are icons only.
> > Actually, only Chinese fonts would become white.  Why do I think it
> > become white words on white background?
> > Please see:
> > http://www.goodhorse.idv.tw/files/screenshot2.png
> > http://www.goodhorse.idv.tw/files/screenshot3.png
> > In screenshot 3 you can see the words on my task bar.  The Chinese words
> > are white, while English words are black.
> > It also happened in the KDE menu:
> > http://www.goodhorse.idv.tw/files/screenshot4.png
> > I tried to create a clean user environment by logging in with an empty
> > home folder.  However this problem was still the same.
> > When I installed kubuntu or Linux Mint 10, this problem didn't happen.
> >  Only Mandriva and Mageia happened.
> > Have you ever seen similar problems before?  Changing the color settings
> > in KDE does not help to solve this problem.
> > Any suggestion or hint is appreciated.
> > 
> > Thanks,
> > Franklin
> Did you try changing the color scheme to Oxygen or any other one?

Yes, I've tried many color schemes.  It did not help.

However, I found that this might be issues about the fonts.  I imported the 
Windows fonts from my Windows partition.  Using Windows fonts are okay, that 
is, the characters shown in the task bar are black, not white.  Then I tried 
some fonts.  Only "AR PL UKai TW" shows black characters.  "AR PL UMing TW", 
or other English fonts like "Dejavu Sans", "Dejavu Serif", ... etc., all show 
white Chinese characters and black English characters.

I have no idea what the fonts the system will use when I specify "Dejavu Sans" 
to the taskbar font and it needs to show Chinese.  I have no idea either why 
some Chinese fonts show white Chinese characters and some (acutally so far 
only one) shows black Chinese characters.

Now my problem can be temporarily solved by specifying the fonts to AR PL UKai 
TW.  However, do you have any idea why this problem would happen?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
URL: </pipermail/mageia-discuss/attachments/20110509/57950401/attachment.asc>

More information about the Mageia-discuss mailing list