[Mageia-discuss] [SOLVED] Re: troubles with update ended with totally dead system.

Juan R. de Silva juan.r.d.silva at gmail.com
Thu Sep 22 04:52:58 CEST 2011

On Wed, 21 Sep 2011 01:52:21 +0000, Juan R. de Silva wrote:

> Hey folks,
> I do not know if it could be seen as a kind of a contribution...
> I installed Mageia 1 almost as soon as it was released for evaluation
> purposes on Dell Latitude d820. Mine is a multiboot environment with
> several distros like Ubuntu Lucid, Fedora 15, Arch, SL 6.1, and a couple
> of others installed.
> I kept playing with it from time to time (my main systems for now are
> Ubuntu Lucid on laptop, and Debian Squeeze on my workstation). I should
> say I was quite impressed, especially considering short time Mageia
> exists.
> Then troubles started. On one of next system updates I had these:
> Sorry, the following packages cannot be selected:
> - kdebase4-runtime-4.6.5-1.1.mga1.i586 (due to conflicts with soprano-
> plugin-virtuoso-2.6.0-0.1.mga1.i586)
> - kipi-plugins-expoblending-1.9.0-3.1.mga1.i586 -
> task-kde4-4.6.5-0.mga1.noarch
> - task-kde4-minimal-4.6.5-0.mga1.noarch (due to conflicts with soprano-
> plugin-virtuoso-2.6.0-0.1.mga1.i586)
> google provided with one link only. It was Mageia forum, not exactly my
> case but had enough to be considered helpful.
> 'rpm -e --nodeps  soprano-plugin-virtuoso' revealled the plugin was not
> installed at all. A little weird, update conflicting with a not
> installed packages, "never mind" I said.
> After run 'urpmi soprano-plugin-virtuoso' and installing the plugin I
> happily get get rid of almost all the above warnings. But still had this
> one:
> Sorry, the following package cannot be selected:
> - kipi-plugins-expoblending-1.9.0-3.1.mga1.i586
> Well, that was quite a progress.
> I run 'urpmi kipi-plugins-expoblending' and on the next update attempt I
> did not get any restricting warnings/errors. So far so good. Finally I
> could proceed with the update.
> It seemed to complete well: no warnings, no errors. Except one little
> dirty thing - the system failed to boot after restart. It stuck at GRUB
> prompt with no errors displayed, just a word "GRUB". No reaction on any
> key, not 'e', not 'c', not 'shift' button, not any others. Not even Ctl-
> Alt-Del. The only way to get out of there was pressing Power Off button.
> Booting from SystemRescueCD and reinstalling grub helped nothing. Plain
> dead system.
> But this was a climax. I get to the Mageia forum, trying to search for a
> clue and get this:
> "Sorry but you cannot use search at this time. Please try again in a few
> minutes."
> And no, folks, I've not reported any bugs. Sorry, far to many... :-( At
> the end I did not try to anything funny here. Just a regular system
> update.

Well, it looks to be solved for now. At least a kind of... What I mean 
I've succeeded to boot the system.

Last time I tried to restore GRUB for 'grub' prompt. And it was in vain. 
Just now I did it differently. I booted from SystemRescueCD and tried 
'grub-install --no-floppy --recheck /dev/sdaX'. It failed complaining not 
finding /boot and/or block device (something like this).

Then I mounted Mageia's / to /mnt and executed:

'grub-install -no-floppy --recheck --root-directory=/mnt /dev/sdaX'

This time it was a success and I can boot now. I tried 'urpmi --test --
auto-update' and get 'nothing to update'. So, I would be curious to see 
what happens at the next update.

However I still consider it "a kind of solved" since the source of the 
problem was not revealed. Thus there is still some bug presented. Though 
it might be resolved after last update. We'll see.

Thanks to all replied.

More information about the Mageia-discuss mailing list