[Mageia-discuss] troubles with update ended with totally dead system.

Juan R. de Silva juan.r.d.silva at gmail.com
Thu Sep 22 03:43:00 CEST 2011

On Wed, 21 Sep 2011 20:05:50 +0200, Maarten Vanraes wrote:

> Op woensdag 21 september 2011 11:32:24 schreef Claire Robinson:
>> On 21/09/11 02:52, Juan R. de Silva wrote:
>> > Hey folks,
>> > 
>> > I do not know if it could be seen as a kind of a contribution...
>> > 
>> > I installed Mageia 1 almost as soon as it was released for evaluation
>> > purposes on Dell Latitude d820. Mine is a multiboot environment with
>> > several distros like Ubuntu Lucid, Fedora 15, Arch, SL 6.1, and a
>> > couple of others installed.
>> > 
>> > I kept playing with it from time to time (my main systems for now are
>> > Ubuntu Lucid on laptop, and Debian Squeeze on my workstation). I
>> > should say I was quite impressed, especially considering short time
>> > Mageia exists.
>> > 
>> > Then troubles started. On one of next system updates I had these:
>> > 
>> > Sorry, the following packages cannot be selected:
>> > 
>> > - kdebase4-runtime-4.6.5-1.1.mga1.i586 (due to conflicts with
>> > soprano- plugin-virtuoso-2.6.0-0.1.mga1.i586)
>> > - kipi-plugins-expoblending-1.9.0-3.1.mga1.i586 -
>> > task-kde4-4.6.5-0.mga1.noarch
>> > - task-kde4-minimal-4.6.5-0.mga1.noarch (due to conflicts with
>> > soprano- plugin-virtuoso-2.6.0-0.1.mga1.i586)
>> > 
>> > google provided with one link only. It was Mageia forum, not exactly
>> > my case but had enough to be considered helpful.
>> > 
>> > 'rpm -e --nodeps  soprano-plugin-virtuoso' revealled the plugin was
>> > not installed at all. A little weird, update conflicting with a not
>> > installed packages, "never mind" I said.
>> > 
>> > After run 'urpmi soprano-plugin-virtuoso' and installing the plugin I
>> > happily get get rid of almost all the above warnings. But still had
>> > this one:
>> > 
>> > Sorry, the following package cannot be selected:
>> > 
>> > - kipi-plugins-expoblending-1.9.0-3.1.mga1.i586
>> > 
>> > Well, that was quite a progress.
>> > 
>> > I run 'urpmi kipi-plugins-expoblending' and on the next update
>> > attempt I did not get any restricting warnings/errors. So far so
>> > good. Finally I could proceed with the update.
>> > 
>> > It seemed to complete well: no warnings, no errors. Except one little
>> > dirty thing - the system failed to boot after restart. It stuck at
>> > GRUB prompt with no errors displayed, just a word "GRUB". No reaction
>> > on any key, not 'e', not 'c', not 'shift' button, not any others. Not
>> > even Ctl- Alt-Del. The only way to get out of there was pressing
>> > Power Off button.
>> > 
>> > Booting from SystemRescueCD and reinstalling grub helped nothing.
>> > Plain dead system.
>> > 
>> > But this was a climax. I get to the Mageia forum, trying to search
>> > for a clue and get this:
>> > 
>> > "Sorry but you cannot use search at this time. Please try again in a
>> > few minutes."
>> > 
>> > And no, folks, I've not reported any bugs. Sorry, far to many... :-(
>> > At the end I did not try to anything funny here. Just a regular
>> > system update.
>> This is a known bug, it *should* be solved now.
>> There is a bug report at https://bugs.mageia.org/show_bug.cgi?id=2097
>> It was quite a bad bug as it did break the update but it brought to
>> light the now infamous bug 2317 -
>> https://bugs.mageia.org/show_bug.cgi?id=2317 - which all updates have
>> to be checked against.
>> We have begun linking any required packages into updates media to
>> prevent any recurrence of that unfortunate incident. If any do slip
>> through the net then the affect you will see is that MageiaUpdate will
>> give an error saying a certain package cannot be selected. Please do
>> report this if you experience it!
>> This only affects MageiaUpdate, so you can still perform the update
>> from the command line as root (urpmi --auto-update) or by installing
>> the updated packages in rpmdrake instead.
>> Hopefully we are on top of this now though and a permanent solution is
>> being worked on behind the scenes.
>> Sorry if you had a bad experience with this.
> Also https://bugs.mageia.org/show_bug.cgi?id=2070
> again, if there is bugs, try to confirm or give help.

Well, with the picture in hand I'd find it quite difficult to report any 
particular bug.

The whole thing involves to many steps to go through and to identify what 
the problem actually was, and when, and what has happened.

I still have an image of the partition with Mageia which was maid at the 
point initial update problem manifested itself reporting a number of 
files that cannot be selected. It would take me just several minutes to 
restore it. I would not mind to do it to help.

However, I would do it only if I know exactly what and at which point 
would be in interest to report and provide being helpful to developers. 
If you or somebody else would be interested to guide me I could do it.

There are only 3 obstacles here. First I'm a GNOME user, so I know little 
about KDE. Second, I've never used neither Mandriva nor certainly Mageia 
before and know about them even less. And third, I'm going to be quite 
busy next month, so there might be some delays in my participation.

If all the above is OK, then I could commit to do it.

> btw: with the grub issue it would be interesting if you could report it
> and post the /root/drakx/install.log file in it. perhaps something odd
> happened during the install.

I could report the file content but I'm afraid it would be of a little 
value, since its timestamp is 2011.08.09 when the crash happened on 
2011.09.20. So, the file contains only an outdated information.

> btw: was it installed using DVD or liveCD?

Sincerely I do not recall. I did not pay attention to details at that 
point, since all I wanted was to give Mageia a try. However I more 
inclined to think it was a liveCD.

The installation was simple. I just accepted all defaults, except the 
location of / and location of GRUB installation. I installed Mageia on a 
separate partition and installed GRUB on the same partition. My Ubuntu 
Lucid was chainloding it. Typical multiboot install. It worked fine up to 
the system update as I described.

Personally, I suspect Mageia had trouble with the GRUB being installed 
not to MBR but in its own partition. But this is a pure speculation.

Another thing to mention. The first time I get the first complains while 
trying to update the system was quite a long time ago, about over a 
month. Since Mageia for was just a "test drive", I left it as it was. So, 
yesterday's update was quite a massive one. If I remember correctly 
something close to 350-400MB.

More information about the Mageia-discuss mailing list