[Mageia-discuss] FVWM in Mageia 2

Brian Schroeder bschroeder at internode.on.net
Sat Nov 24 10:34:10 CET 2012

As a long-time Mandrake/Mandriva user I have been lurking on this list 
since it started.  I have now installed Mageia for the first time on my 
new computer and am running into lots of little issue.

For many years I used FVWM2, but in Mandriva 2011 I switched to Metisse, 
and decided I quite liked it.  Unfortunately metisse seems to have 
died.  I tried KDE and Gnome on Mageia but don't really like them, so I 
decided to go back to fvwm2 - along with all my customisations from 
times past.

In trying to update my old config file to work with the newer system I 
checked out the PipeRead command in the official config file where it 
calls the "xdg_menu" command.  I tried it out on the command line to see 
what output it produced and found quite a few errors:

/usr/bin/xdg_menu --format fvwm2 --charset UTF-8

WARNING: '/etc/xdg/kde/menus/kde-settings.menu' does not exist
WARNING: '/etc/xdg/kde/menus/kde-information.menu' does not exist
WARNING: '/etc/xdg/kde/menus/kde-settings.menu' does not exist
WARNING: '/etc/xdg/menus/applications-kmenuedit.menu' does not exist
Unknown 'Layout':
         'HASH(0x20e2310) 0
      Menuname ARRAY(0x20e2460) 0
      Menuname ARRAY(0x20e2550) 0
      Menuname ARRAY(0x20e2640) 0

So, is xdg_menu still valid, or is it broken?  Is it still usable as 
designed, or do I need to find another way to do this?


More information about the Mageia-discuss mailing list