[Mageia-discuss] Mageia 2 Experiences

Frank Griffin ftg at roadrunner.com
Fri Apr 27 14:10:15 CEST 2012

On 04/27/2012 07:43 AM, imnotpc wrote:
> The problems installing mga2 on this laptop are truly puzzling. Here's 
> a current summary:
> I've done a clean install of mga2 and the default boot entry still 
> hangs with a blank screen.

I'll say again, have you tried installing the radeon-firmware ?  The 
problems in cauldron with different ATI chips are well-known and are 
being worked on.  Some work in text mode with nokmsboot, and some 
don't.  Yours doesn't appear to, so you're stuck using the firmware.

> How quickly you start the boot changes the outcome of the boot. I can 
> now duplicate different outcomes when I start the boot at different 
> times during the first 0-2 seconds after the boot menu appears.

This may be misleading.  At least some of the ATI driver problems 
involve kernel loops of varying length trying to allocate memory without 
success.   There's really nothing to be done here except to give the 
driver what it needs.

> If I immediately select the safe mode menu item I can now get to a 
> command line. If I wait longer it will hang at 2 different points 
> depending on how long I wait.
> The wired network connection doesn't work after booting. If I run 
> drakconnect I can see that the settings are correct for the wired 
> interface and there is no entry for the wireless interface. When I 
> save the setting drakconnect locks up while testing the connection. If 
> I disable the wired interface drakconnect saves and exits without 
> problem. However when I reboot the default boot entry now locks up 
> while trying to start the network: "Starting LSB: Bring up/down 
> networking..."
> I install over the network so I know there is no additional firmware 
> required for the wired interface. I'm open to suggestions (other than 
> chucking the laptop out the window, which is a very appealing idea 
> right now!)
  I'll say again, check to see whether NetworkManager is controlling 
your NIC, and try disabling it if it is.  And check your syslog for 
messages relating to eth0 on startup.

More information about the Mageia-discuss mailing list