[Mageia-discuss] Mageia 2 install report

AL13N alien at rmail.be
Mon Jun 4 20:45:08 CEST 2012

Op maandag 4 juni 2012 12:53:40 schreef Luiz Alberto Saba:
> Hi
> Finally I've installed Mageia 2 on my home machine.
> There are a few problems.
> There it goes...
> Hardware:
> MB Asus P6T Deluxe V2
> Intel i7 950 CPU
> 12 GB of Corsair RAM
> nVidia GeForce 9800 GTX
> 4 HDs jbod
> 1 RAID 0 controlled by RAID bus controller: Silicon Image, Inc. Device 0242
> 1 scenario
> I've tried to install with the full hardware configuration.
> No go.
> The installer made mistakes with the RAID 0. Both disks was listed at
> the partitioning step (not counting the /dev/mapper/... entry). I can't
> see why the individual disks was listed, since the array was recognized.
> Worst of all, the installer gives a message that can't format a swap
> partition at one of the RAID disks. It shouldn't. The RAID is windows
> and DON'T have a swap partition at all.
> 2 scenario
> Removed the RAID array and tried again.
> I was able to install Mageia 2 but not able to boot correctly after the
> install. Systemd messages of error and I could not deal with them.
> Since the fourth disk is a openSUSE 12.1 disk, I've tried to remove and
> install again without the disk.
> 3 scenario
> Installer did what was expected. No errors, boot ok, subsequent updates
> fine.
> Then I've reinstalled the Suse disk. No problems.
> Then I've reinstalled the RAID array.
> I was able to manually mount the Windows partition, but diskdrake is
> showing the individual disks again. The second disk of the array is
> completely crazy, showing 3 partitions (2 linux native and 1 swap).
> Since the array is working fine with windows, it CAN'T be right.

in short, your hardware RAID is a fake RAID. in linux it means that you have 
access to both the normal disks and the raid array.

the reason for this is that the raid array is sort of a software raid wrapper 
in firmware, but it'll make your raid slower than it would in linux as a linux 
software RAID.

that being said, likely systemd and installer will try to look and use 
whatever disks it can see, it likely doesn't know what the raid is looking 
like and so it likely tries to guess...

that being said, i don't know much about this. i would advise you to file a bug 
report so the people who know about this sort of thing can answer you in the 

More information about the Mageia-discuss mailing list