[Mageia-dev] Changing default media names

Samuel Verschelde stormi at laposte.net
Sun Nov 20 21:18:01 CET 2011

Le dimanche 20 novembre 2011 19:43:55, nicolas vigier a écrit :
> Hello,
> The media names on Mageia 1 and Cauldron currently look like this, when
> added with urpmi.addmedia --distrib :
>  Core Release
>  Core Release Debug
>  Core Updates
>  Core Updates Debug
>  Core Backports
>  Nonfree Release
>  Core 32bit Release
>  Core 32bit Updates
>  ...
> I suggest we replace them on Cauldron and later versions with names
> like this :
>  cauldron/x86_64/core/release
>  cauldron/x86_64/debug/core/release
>  cauldron/x86_64/core/updates
>  cauldron/x86_64/debug/core/updates
>  cauldron/x86_64/core/backports
>  cauldron/x86_64/nonfree/release
>  cauldron/i586/core/release
>  cauldron/i586/core/updates
>  ...
> I think it's better because :
>  - it doesn't have spaces, so doesn't need to be quoted in urpmi command
> lines - doesn't have capitals, so easier to type right
>  - includes version of Mageia, so you can quickly see which version(s)
>    you're using
>  - match the paths on the mirrors, so I think it's more clear what the
>    media is and easier to remember
> What do you think ?

I'm not sure about it. I see the benefits, but to me there is a major drawback: 
they are not user-friendly :
- current names are readable, new ones aren't, they're just technical
- current naming scheme doesn't bother you with arch information, except on 64 
bits system and only for 32 bits media
- the order of items in current scheme is better : first you see whether it's 
Core, Nonfree or Tainted, then if it's Release/Updates/Backports/Updates 
Testing/Backports Testing, and then debug media have some more information. 
Release and arch are important but many media share the same release and arch 
on a given system, so the information should be more discreet.

This proposal looks good for CLI but not for GUI. I share the objectives, but 
am not entirely convinced by the current proposal, unless it comes with 
improvements on the UI side.

Some ideas :
- change the naming scheme but translate it into human readable names in UI
- Implement item 40 for mageia 2 specs : "really use media tags in the package 
managers, CLI and GUI: testing, backport, update, etc. Currently, apart from a 
hack for media which name contain “backport”, the nature of the media is not 
used in urpmi and rpmdrake whereas it could be used to improve usability a 
lot. Instead of talking about core-updates, core-updates_testing, etc., talk 
about the root media (“core”, “non-free”, “tainted”) and let users choose 
whether they want to use updates, backports, updates_testing, 
backports_testing flavors of this root media." I haven't had the time to write 
a complete spec for that, but if needed I could try to put it higher on my 
TODO list.

Best regards

Samuel Verschelde

More information about the Mageia-dev mailing list