[Mageia-discuss] Mageia 2 Experiences

imnotpc imnotpc at Rock3d.net
Thu Apr 26 15:41:32 CEST 2012

On 04/26/2012 08:38 AM, Frank Griffin wrote:
> On 04/26/2012 07:50 AM, imnotpc wrote:
>> On 04/25/2012 10:32 PM, Frank Griffin wrote:
>>> If you boot a rescue CD, mount the root partition, change the 
>>> runlevel in /etc/inittab to 3 rather than 5, and reboot, do you get 
>>> to a login prompt with no problem ?
>> No, it locks up with a blank screen. The last line I could read 
>> before it went blank was "Starting speech dispatcher..."
>> If I boot using safe mode the system doesn't lock, but doesn't give 
>> me a command prompt either. The last message is "Failed to issue 
>> method call: Transaction is destructive."
> OK, there may be several issues in play here.
> Cauldron currently starts plymouth on tty1 to display boot messages, 
> and I think the design relies on a Display Manager (GDM, KDM) 
> signalling plymouth to exit, so if you boot to runlevel 3 (where no DM 
> is staretd, plymouth currently hangs around on tty1, and it looks like 
> it's hung.  However, if you do ALT-F2 (or 3, 4, etc), switching to an 
> available tty that isn't running X should start getty there and give 
> you a login prompt.

Doing a default boot the system definitely locks up. Even the cap lock 
key doesn't work.

> What I'm trying to determine is whether your line-mode tty video works 
> without X in the picture.
> If you could read "Starting speech dispatcher", then your tty was 
> working, and the blank screen was probably the result of starting X.  
> Maybe with systemd now, there is a different way of setting the 
> runlevel.  Try booting in safe mode, doing ALT-F2, logging in as root, 
> and running XFdrake.  Then uncheck the box which says start graphical 
> mode at boot, and try again.

When I boot using safe mode ALT-F2 does nothing. Interestingly 
CTL-ALT-DEL works even though there is no command prompt.

I installed mga2 as an upgrade to mga1 so the old boot entry is still 
there. When I use it the system boots to the regular login screen, but 
the mouse and keyboard don't work so there is nothing I can do from there.

In the past I've used the net install disc and done an "upgrade" of the 
installed system. Nothing is actually installed but it does allow me to 
change some settings. Perhaps use that to uncheck the graphic interface box?

>> I install over the network so the wired NIC is working during 
>> installation. The wireless NICs work as well but they usually need 
>> firmware installed first. I'll take a look at this once I can 
>> reliably get that far. Thanks for the help.
> If your NICs worked under mga1, NM is most likely the culprit.
> If the wired NIC works during installation, then it doesn't need 
> firmware, and there's no reason it shouldn't work in the new system.

Correct, the wired NIC doesn't require firmware. The built in wireless 
NIC needs additional firmware. When you set up the interface it asks to 
install the firmware and it always has worked fine after that. The 
PCMCIA wireless NIC has needed firmware in the past, but mga1 seems to 
install everything it needs during installation. Installing Linux on a 
laptop has always been difficult, but despite my current woes laptop 
support has gotten much better over the years.

More information about the Mageia-discuss mailing list